Photo

P2P connection

  • Please log in to reply
 

#1 Toszi Toszi

Sat, 11 February 2017 22:28

Hi.

 

Me and Nexi are having problems with p2p connection. We are connected to the same cable modem and we cannot get dirrect connection betwen us (even via LAN). We see each other servers in games  but when we try to connect it fails. Hamach/Evolve are not working aswell for us.

 

If we want to play For Honor or recently Ghost Recon Beta we cannot join same team due to this issue (they use p2p...) and one of us have to use Nexi's LTE which sucks when it comes to stable connection for gaming.

 

I tried to contact with our Internet provider but sadly every time I called them on other side was someone who had no idea at all about internet stuff... (they were saing "I will mute myself for moment" which obviously means they were asking someone for help) the only thing I got from them is that "they are not blocking anything".

 

I suck when it comes to this sort of things so we are looking for some help.


 

#2 Marakai Marakai

Sun, 12 February 2017 13:40

1st thing to try is to disable Windows Firewall on all machines. If you're behind an internet router, it's not necessary to have this switched on anyway.

2nd problem could be the NAT of your router. When you connect out, it will give you a random port and connect back in on a specific port. This port will then be mapped to forward to a particular machine. When the second person tries to connect, the same thing happens, except the port is already mapped. When the first person attempts to connect back to the second, they end up connecting to themselves (which gets rejected). This is typically bad coding on part of the game developer but also a problem with NAT itself. A lot of modern router software fixes this by virtualising the port and looking at header information before re-forwarding, but not everything supports it.

 

EDIT: You can try and fix the NAT problems by configuring NAT Reflection. Although a lot of off-the-shelf routers you buy from store or get given by your ISP don't allow this kind of setup. But if you can the settings are:

 

1. NAT Reflection Mode - PURE

2. Enable NAT Reflection for 1:1 mapping - OFF

3. Enable automatic outbound NAT Reflection - ON

 

If you have to set specific interfaces ensure you select both LAN and WAN. Another thing that might also help is to disable Large Packets (also called Huge Packets) and to set your MTU to below 1500 (1492 is the generally accepted max in UK)


Edited by Marakai, Sun, 12 February 2017 13:48.

 

#3 Toszi Toszi

Sun, 12 February 2017 14:02

We tried disabling Firewall/Kaspersky, it didn't help.

 

For 2nd point is there anything I can do? Even if i buy my own router i will have to connect it to provider cable modem so from what you said it won't help at all. I can also ask provider to get me new cable modem model since I know that they have it but as far as I know they give it only to new customers and I tried this long time ago. Changing provider is not a option since at my place other are awful and cost way more and not necessarily fix the problem.

 

 

EDIT:

 

Problem is that I can't configure cable modem only provider can do it...


Edited by Toszi, Sun, 12 February 2017 14:25.